easy_install only stable packages

exhuma.twn exhuma at gmail.com
Mon Sep 10 13:58:30 CEST 2007


easy_install is great. But it always automatically installs the
*latest* version. Even if that is beta,alpha (or however else the
developers call it). Is there no switch or possibility to disable this
feature? So that it installs the latest *stable* version?

I know that you can specify a specific version of a package with (for
example)

easy_install -U "SQLAlchemy==0.3.10"

This is undocumented on the web-page by the way ;)
But having to specify the version number for each package is quite
cumbersome.




More information about the Python-list mailing list