newbie: self.member syntax seems /really/ annoying
steve at REMOVE-THIS-cybersource.com.au
Thu Sep 13 15:55:28 CEST 2007
On Thu, 13 Sep 2007 12:10:03 +0000, timothy.soehnlin at gmail.com wrote:
> Why not use '_' as the self variable. It is minimal and achieves close
> to '.var', as '_.var' isn't that different. I know its a little
> perl-esque, but its not a bad convention if you are aiming to up
> readability of your code.
I think the definitions of "up" or "readability" you are using are very
different from mine. To me, to up something means to increase it, and
readability means the ease of comprehension when reading something. You
seem to be using the opposite definition for one or the other.
More information about the Python-list