Mac OSX sqlite problem. Missing?

Diez B. Roggisch deets at nospam.web.de
Mon Sep 10 22:39:22 CEST 2007


ricardo.turpino at gmail.com schrieb:
> Hi,
> 
> I've installed Mac Python 2.5.  I'm running Mac OS X 10.4.10 on a
> Macbook 1.83GHz.  I though that the python sqlite library was
> installed by default as part of Mac Python 2.5, however, I still have
> a problem.
> 
> Sqlite does not appear to be my system:
> 
>>>> import sqlite
> Traceback (most recent call last):
>   File "<stdin>", line 1, in <module>
> ImportError: No module named sqlite
> 
> I ran 'sudo easy_install pysqlite' which gave me the file
> 'pysqlite-2.3.5-py2.5-macosx-10.3-fat.egg', but no working pysqlite.
> 
> I then downloaded the source files and ran 'python ez_setup.py
> pysqlite==2.3.5', which told me 'Using /Library/Frameworks/
> Python.framework/Versions/2.5/lib/python2.5/site-packages/
> pysqlite-2.3.5-py2.5-macosx-10.3-fat.egg'
> 
> Still no working version of pysqlite.
> 
> Tried installing from source.  No problems appeared, but I still can't
> use pysqlite.
> 
> The reason I am trying to install pysqlite, is to use turbogears,
> which initially failed when I ran 'tg-admin sql create', it failed
> with 'import sqlite.  ImportError: No module named sqlite'.
> 
> Any ideas gratefully received.

Are you by any chance using the python 2.3 when issuing that import 
statement?

Diez



More information about the Python-list mailing list