Python 2.5 adoption

Lie Lie.1296 at gmail.com
Sun Apr 20 11:16:40 CEST 2008


On Apr 19, 1:08 am, Joseph Turian <tur... at gmail.com> wrote:
> How widely adopted is python 2.5?
>
> We are doing some development, and have a choice to make:
> a) Use all the 2.5 features we want.
> b) Maintain backwards compatability with 2.4.
>

There is another choice: Develop with future in mind because it's
possible that when you finished version 1, what seemed to be future
would become the present. This is especially if the project is big and
requires years to complete.

On Apr 19, 5:13 pm, Graham Breed <x31equse... at gmail.com> wrote:
> My web host uses 1.5.2.  That is painful.

If them using 1.5.2 is painful for you ask the host to install
something newer (AFAIK it is possible to run several python versions
side-by-side) or prepare yourself to move to other host.



More information about the Python-list mailing list