[Python 2.4/2.5] subprocess module is sorely deficient?

Mark Wooding mdw at distorted.org.uk
Wed Apr 23 16:38:45 CEST 2008


Harishankar <v.harishankar at gmail.com> wrote:
> On Wednesday 23 Apr 2008 15:11:21 Ben Kaplan wrote:
>> I don't know about all Linux distros, but my Ubuntu machine (8.04 Beta),
>> has the 'TERM' (xterm) and 'COLORTERM' (gnome-terminal) keys in os.environ.
> This is set on Debian too. Thanks. I should be able to use this environment 
> variable on most Linux distributions, I suspect.

No!  The TERM variable is not the name of a terminal emulation program!
It's a terminal name intended to be looked up in the termcap and/or
terminfo databases.  For example, I use pterm as my terminal, but it
(correctly) sets TERM=xterm.

I'd suggest trying to run (in order, until one actually works):
$X_TERMINAL_EMULATOR, sensible-x-terminal-emulator, x-terminal-emulator,
xterm.

-- [mdw]



More information about the Python-list mailing list