python-mode errors

Fredrik Lundh fredrik at pythonware.com
Sun Aug 17 22:56:20 CEST 2008


Rustom Mody wrote:

> When I start python mode I get the error:
> 
> idle error: #<buffer easygui.py> -Wrong number of arguments : #<subr
> set-match-data> 2"
> 
> The Python mode version is 4.78
> 
> Is this a known problem?

there are plenty of google hits for that message, and they all seem to 
agree that the problem is caused by using ELC files generated for a 
newer emacs with an older version.  try loading the EL file to see if 
the problem goes away.

</F>




More information about the Python-list mailing list