What about a decorator module version 3.0?

Michele Simionato michele.simionato at gmail.com
Tue Dec 2 07:23:55 CET 2008


On Dec 1, 9:18 pm, Terry Reedy <tjre... at udel.edu> wrote:
>
> Release a final 2.x version with whatever internal changes but with
> external api unchanged or at least backward compatible.  Mark items to
> be deleted as deprecated.  Keep that available indefinately.
>
> Then release a 3.0 version with Py3.0 support and deprecated items deleted.

Uhm ... I don't like that. I want the 2.x versions to be
fully compatible, without any annoying warning. The warnings
will be in 3.0 and the functionality will be removed in 3.1.
BTW, I have uploaded versions 2.3.2 on PyPI and it is intended
to be the last version of the 2.x series.



More information about the Python-list mailing list