Problem Python 2.6.1 vs 2.6 & pyWin32

Michel Claveau - NoSpam SVP ; merci noZ.spamZ at ZZ.ZsvpZ.com
Mon Dec 15 16:13:20 CET 2008


Hi, all!

I have several softwares using Python+PyWin32, often as COMèserver. Ok 
with Python 2.5.x.  I want migrate to Python 2.6.
But when I install  python-2.6.1.msi + pywin32-212.win32-py2.6, my softs 
don't run.
Tried on five machines (two XP & three Vista).

But... if I install  python-2.6.msi ,  IT'S OK!!!

And, if I installl 2.6.1 once again, after 2.6, ... don't run ???!!! 
;-(((

In reality, soft run, but COM server can not be used. I get these 
messages :

  File "C:\Python26\Lib\site-packages\win32com\server\policy.py", line 
728, in resolve_func
    module = _import_module(mname)
  File "C:\Python26\Lib\site-packages\win32com\server\policy.py", line 
747, in _import_module
    __import__(mname)
  File "C:\Ponx\ponx.py", line 54, in <module>
    import socket
  File "C:\Python26\lib\socket.py", line 46, in <module>
    import _socket
<type 'exceptions.ImportError'>: DLL load failed: Le module spécifié est 
introuvable.


"Erreur non spécifiée"  (with call from JScript test, or VBScript test). 
(These tests run OK with  2.6 or 2.5.x)


I am very disappointed.  Help me, please.
Thanks in advance.

*** and sorry for my bad english ***


@-salutations
-- 
Michel Claveau






More information about the Python-list mailing list