Can´t Surf Python Pages in Windoze

Tino Wildenhain tino at wildenhain.de
Fri Dec 26 16:43:27 CET 2008


hi,

Victor Subervi wrote:
> Hi;
> 
> I try to surf to this code in Windoze and it doesn't work...just posts a 
> small, black screen for a split second. Why?

I don't know what "surf this code" means (or what Windoze should be)

> print "Content-Type: text/html"
> print
> print """
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" 
> "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
> <head>
> </head>
> <body>
> Yeah
> </body>
> </html>"""

this could be fine if called in CGI context.

> Also, Zope is installed, but when I go to:
> localhost:8080/manage_main
> or
> local:8080/Zope-Instance/manage_main
> I get a 404, after having started the service and everything is go. I 
> have Python up. What gives?

Don't know what "gives" but how did you make sure Zope could
really start and bind the port? There are a lot things which could
go wrong: Applications using this port already, firewall in your
way...

a 404 however indicates the service is there but you are not authorized.
Please read "User and Permission" chapter in the zope book.

Please note the above code you cited is not useable (or sensible) in a
zope environment.

Happy coding
Tino

> Victor
> 
> 
> ------------------------------------------------------------------------
> 
> --
> http://mail.python.org/mailman/listinfo/python-list

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3241 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://mail.python.org/pipermail/python-list/attachments/20081226/614189e6/attachment.bin>


More information about the Python-list mailing list