Guido's new method definition idea

Andreas Waldenburger geekmail at usenot.de
Sun Dec 7 18:10:54 CET 2008


On Sun, 07 Dec 2008 02:49:27 -0500 acerimusdux
<acerimusdux at comcast.net> wrote:

> I'm not sure though whether allowing both syntaxes would make things 
> more or less confusing. It might actually be helpful in some respects 
> for newcomers to realize that self.method(arg) is somewhat the same
> as method(self, arg). [snip]

A professor of mine once said something to the effect that in teaching
it is not so important to ­*tell* people a lot but to *omit* as much as
practically possible. This might be the single most wise thing I have
ever heard.

If you're a newbee and you know nothing of the language, and probably
nothing about programming at all, having two possibilities will
thoroughly confuse you. Only when you have a working(!) knowledge of
one version will you be able to appreciate the other. Since in this
case the other option has no practical benefits whatsoever (IMHO),
there's absolutely no need for it.


/W
PS: I will state again that I do like the idea in itself, its just about
20 years too late for it.


-- 
My real email address is constructed by swapping the domain with the
recipient (local part).




More information about the Python-list mailing list