Problem Python 2.6.1 vs 2.6 & pyWin32

"Martin v. Löwis" martin at v.loewis.de
Tue Dec 16 00:21:36 CET 2008


>> Try installing Python 2.6.1 "for all users".
> 
> Could you clarify why that's needed?

I didn't say it's needed. I said that he should try that, perhaps it
helps.

> One thing we noticed (I'm not sure has this been yet submitted to
> bugs.python.org yet) was that installing packages created with Python
> 2.5 to Python 2.6 failed unless Python was in %PATH% [1].

In general, that's not supported at all. You will have to rebuild all
packages for Python 2.6, unless they are pure-python packages (in
which case PATH should be irrelevant).

If the .pyd files would have loaded, Python would have complained that
they originate from the wrong Python version.

> Another pretty severe problem was that installers created with Python
> 2.6 didn't work at all with older versions [2].

That's not a bug, either. It has been that way since Python 1.4 or so:
.pyd files built for X.Y won't work for X.(Y+1), and vice versa.

It seems that you mean something specific with the word "installer";
I think you should elaborate what precisely you are referring to.

Regards,
Martin



More information about the Python-list mailing list