"as" keyword woes

Alan G Isaac aisaac at american.edu
Thu Dec 4 21:15:22 CET 2008


Warren DeLano wrote:
> what I can't understand is the decision to break 2.6 instead of 3.0.  2.x was
> supposed to remain backwards compatible, with the thinking that 2.x
> would be maintained in parallel for quite some time.  3.x was supposed
> to be the compatibility break.


I do not understand why anyone would object
to this perfectly cogent complaint of Warren's.
Even if the deprecation warnings had not been
invisible, the complaint would be valid.

Alan Isaac



More information about the Python-list mailing list