Fw: error in importing scipy

Robert Kern robert.kern at gmail.com
Wed Feb 13 18:47:43 CET 2008


Mani Chandra wrote:
> 
> 
> --- On Wed, 13/2/08, Mani Chandra <mc_i2020 at yahoo.co.in> wrote:
> 
>> From: Mani Chandra <mc_i2020 at yahoo.co.in>
>> Subject: error in importing scipy
>> To: python-list2 at python.org
>> Date: Wednesday, 13 February, 2008, 9:30 PM
>> Hi
>> I get the following error while importing scipy. 
>> /usr/local/lib/python2.4/site-packages/scipy_base/__init__.py:16:
>> RuntimeWarning: Python C API version mismatch for module
>> fastumath: This Python has API version 1013, module
>> fastumath has version 1012. import fastumath # no need to
>> use scipy_base.fastumath
>>
>> Can someone please help me out?

Your scipy was built against an older version of Python than the one you are 
trying to run it with. Rebuild scipy with your current version of Python.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco




More information about the Python-list mailing list