mod-python on Mac OSX 10.5

Arnaud Delobelle arnodel at googlemail.com
Tue Jan 8 22:59:37 CET 2008


On Jan 8, 5:27 am, Gnarlodious <lists.gnarlodi... at gmail.com> wrote:
> I am trying to install mod_python on OSX 10.5, Intel version.
>
> sudo apachectl configtest tells me this:
>
> httpd: Syntax error on line 114 of /private/etc/apache2/httpd.conf:
> Cannot load /usr/libexec/apache2/mod_python.so into server:
> dlopen(/usr/libexec/apache2/mod_python.so, 10): no suitable image
> found. Did find:\n\t/usr/libexec/apache2/mod_python.so: mach-o, but
> wrong architecture
>
> I attempted to follow instructions found on these pages but it didn't work:
>
> <http://mike.crute.org/blog/2007/11/08/mod_python-on-leopard/>
>
> <http://farbflash.de/cgi-bin/blosxom.cgi/Dokumente/MacOSX/Leopard/Apac...>
>
> Can
>
> anyone tell me what is causing this error?

(Sorry no time to read the references you provide)

This is because httpd is running in 64 bits (arch x86_64) but
mod_python.so is only 32 bits by default.  You need to modify this.
what I did was:

make the following changes to src/Makefile:
* Add -arch x86_64 to the LDFLAGS line
* Change the build line in mod_python.so to:
        $(APXS) $(INCLUDES) -c -Wc,"-arch x86_64" $(SRCS) $(LDFLAGS) $
(LIBS)

Now that I look at this, I don' know if both are necessary... But it
worked for me.

There was a discussion to the mod_python mailing list in october 2007:

http://www.modpython.org/pipermail/mod_python/2007-October/

--
Arnaud




More information about the Python-list mailing list