Requires a character ... !!

Fredrik Lundh fredrik at pythonware.com
Thu Jul 24 11:47:56 CEST 2008


karthikbalaguru wrote:

> The requirements state that it needs Python 2.2, But i wonder
> how that program has been implemented using Python 2.3 features.
> Anyhow, this has to be resolved and i need your help.

No, you need the help of the original author.  He/she might have
forgotten to update the requirements page, or you may have mis-
read the information.  Only the author knows if this program might
have a chance of working on 2.2.

What program is this?  Can you point us to the site where you
got it?

> Kindly let me know a trick to make to resolve
> the 'in' operator related problem by using Python 2.2.

Instead of backporting the software, why not just update to Python
2.3 or newer and be done with it?  Why insist on using a Python version 
that's nearly seven years old, when the program you're trying to run 
obviously wasn't written for it?

(Note that you can have multiple versions of Python installed on the 
same machine.  Maybe you already have -- have you tried running the 
program with "python2.3" or "python2.4" or "python2.5" instead of just 
"python"?)

</F>




More information about the Python-list mailing list