A fix for OverflowError in 64bits platforms

Manuel Vazquez Acosta mva.led at gmail.com
Fri Jul 4 17:53:43 CEST 2008


Terry Reedy wrote:
> Manuel Vazquez Acosta wrote:
>> Hi all,
>>
>> I'm debugging a Plone site in an AMD64 laptop. When I first tried to run
>> Zope, I got this exception:
> 
> In general, versions numbers for both Python and the app are helpful.
> 

Python 2.4.5, Plone 2.5.5, Zope 2.9.8final

>> OverflowError: signed integer is greater than maximum
>>
>> In the archives I encounter no solutions.
> 
> Archives: Python? Zope? Plone?

The three of them ;)

> 
>> This is what I could find, so I share with you all:
> 
> I hope you have/will report this to the appropriate place.
> 

Well, not sure where to report to. According to your last comment, is an
Archetypes' bug, isn't it? So it's best to report it there.

>>
>> I think the docstring should be appended with a "Note: On 64bits
>> platform this raises an OverflowError blah blah..."
> 
> Better to fix it ;-)

Ok.

Best regards,
Manuel.




More information about the Python-list mailing list