Boolean tests

Steven D'Aprano steve at
Wed Jul 30 01:42:59 CEST 2008

On Tue, 29 Jul 2008 21:25:44 +0100, Matthew Woodcraft wrote:

> Ben Finney  <bignose+hates-spam at> wrote:
>> No, he retracted the *insult* and restated the *advice* as a distinct
>> statement. I think it's quite worthwhile to help people see the
>> difference.
> Ben, it was quite clear from Anders' post that he knows about
> __nonzero__ . That's why the so-called advice is insulting. The original
> phrasing was just the icing on the cake.

Anders wrote:

"But then you decide to name the method "__nonzero__", instead of some 
nice descriptive name?"

That suggests to me that Anders imagined that __nonzero__ is something I 
just made up, instead of a standard Python method. What does it suggest 
to you?


More information about the Python-list mailing list