Requires a character ... !!

alex23 wuwei23 at gmail.com
Thu Jul 24 11:47:10 CEST 2008


On Jul 24, 7:33 pm, karthikbalaguru <karthikbalagur... at gmail.com>
wrote:
> Kindly let me know a trick to make to resolve
> the 'in' operator related problem by using Python 2.2.

You seem to be making life -very- difficult for yourself.

Your distro is running Python 2.4, you've gone out of your way to get
Py2.2 installed. Why are you so convinced that you -need- Python 2.2
over 2.4? Everyone problem you've posted here seems due to that
assumption...

Generally, Python is pretty good about backwards compatibility. Code
written for 2.2 should run fine under 2.4. As you're discovering, the
opposite isn't true. __future__ isn't a cure-all.



More information about the Python-list mailing list