working pylint anyone?

Mike Driscoll kyosohma at gmail.com
Thu Jul 31 15:05:51 CEST 2008


On Jul 31, 4:29 am, "Diez B. Roggisch" <de... at nospam.web.de> wrote:
> Hi,
>
> until yesterday I was a happy user of pylint. Then I upgraded to ubuntu
> hardy heron - and the trouble began.
>
> The packaged version of pylint (0.13.2) fails with this error (last line):
>
> logilab.common.configuration.UnsupportedAction: callback
>
> The same error happens if I use
>
> easy_install-2.5http://release.ingeniweb.com/third-party-dist/logilab.installer-0.1.tgz
>
> as found on the net. Using easy_install pylint misses logilab-common &
> astng, installing these additionally (easy_install) creates two eggs - but
> unfortunately, the don't actually create a namespace-package logilab,
> instead either one of them is picked up depending on installation order.
>
> Then I tried the source releases - no luck either, either they produce the
> same error or something similar.
>
> I tried looking into the MLs - the last posts are from around 2006, so I
> refrained from actually subscribing.
>
> So - anybody out here having an actually working pylint config and can tell
> me what versions work together? I've become pretty dependend on it to be
> honest...
>
> Diez

For future reference, I found this installer package helpful in
getting PyLint and its dependencies to all install correctly:

http://tarekziade.wordpress.com/2008/02/20/pylint-installation-made-easier/
http://pypi.python.org/pypi/logilab.pylintinstaller

I used it on Windows, but it should (theoretically) work on Linux just
as well.

Mike



More information about the Python-list mailing list