site-packages, unzipepd there but import fails

Bruno Desthuilliers bruno.42.desthuilliers at websiteburo.invalid
Thu Jul 3 17:09:45 CEST 2008


defn noob a écrit :
> i unzipped 

what ?

> and put the folder

which folder

> in site-packages.

which one ? (remember that if you have more than one Python installation 
on your machine, you'll have more than one site-packages too).

> when i run setup.py
> install nothing happens.

Well... usually, setup.py install takes care of putting the appropriate 
things at the appropriate place for your system, so you don't have to 
"put the folder in site-packages" by yourself.

> when i do import pp from shell

Which shell ? The Python shell ? A bash shell ?

> it complains it doesnt exist.
> 
> isnt placing the folder in site-packages enough?
> 

move "the folder" from site-packages to somewhere else, cd to "the 
folder", then run python setup.py install (with appropriate permissions 
of course). And if you have more than one python install on your system, 
make sure the one you're using for running setup.py is the right one.


> these setup.py-files often dont work

Python-version confusion issues set aside, I've never had any problem 
with a setup.py so far (for 'so far' == since I've started using Python 
some height years ago). But I admit I never tried to copy "the folder" 
into site-packages *then* run setup.py install from there...





More information about the Python-list mailing list