How to make py2.5 distutil to use VC2005?

David Cournapeau cournape at gmail.com
Wed Jun 4 15:47:45 CEST 2008


On Wed, Jun 4, 2008 at 11:38 AM, 甜瓜 <littlesweetmelon at gmail.com> wrote:

>    Well, IMO, the format of binary files generated by VC2003 and
> VC2005 is compatible in most cases.

Problem arise with the C runtime, not with object file format. In
particular, python uses the C api for file handling, and the standard
C is definitely not ABI compatible within VS versions.

I strongly advise you against using VS 2005 (with the binary python;
if you build python by yourself, then no problem; I don't know if it
is possible to build python with VS 2005). You *will* get crashes in
many cases.

David


More information about the Python-list mailing list