does paramiko support python2.5?

Praveena B praveena_python at yahoo.com
Wed Jun 11 21:23:38 CEST 2008


when i used paramiko in python2.5 i got the error below.
  File "C:\praveena\python scripts\sshlib\ssh.py", line 5, in <module>
    import paramiko
  File "C:\Python25\Lib\site-packages\paramiko\__init__.py", line 69, in <module>
    from transport import randpool, SecurityOptions, Transport
  File "C:\Python25\Lib\site-packages\paramiko\transport.py", line 32, in <module>
    from paramiko import util
  File "C:\Python25\lib\site-packages\paramiko\util.py", line 31, in <module>
    from paramiko.common import *
  File "C:\Python25\lib\site-packages\paramiko\common.py", line 98, in <module>
    from osrandom import OSRandomPool
  File "C:\Python25\Lib\site-packages\paramiko\osrandom.py", line 129, in <module>
    raise ImportError("Cannot find OS entropy source")
ImportError: Cannot find OS entropy source
can anyone help me?
thanks,
Praveena


      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-list/attachments/20080611/4d015b07/attachment.html>


More information about the Python-list mailing list