Pystemmer 1.0.1 installation problem in Linux

Miki miki.tebeka at gmail.com
Thu Mar 27 19:07:41 CET 2008


Hello Supheakmungkol,

> I am a newbie to Python community. For my project, I tried to install
> Pystemmer 1.0.1 (http://snowball.tartarus.org/wrappers/
> PyStemmer-1.0.1.tar.gz) on my linux ubuntu 7.10 machine but
> unsuccessful. It produced the following error:
>
> running install
> running build
> running build_ext
> building 'Stemmer' extension
> gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O2 -Wall -Wstrict-
> prototypes -fPIC -Isrc -Ilibstemmer_c/include -I/usr/include/python2.5
> -c libstemmer_c/src_c/stem_ISO_8859_1_danish.c -o build/temp.linux-
> i686-2.5/libstemmer_c/src_c/stem_ISO_8859_1_danish.o
> In file included from /usr/lib/gcc/i486-linux-gnu/4.1.3/include/
> syslimits.h:7,
>                  from /usr/lib/gcc/i486-linux-gnu/4.1.3/include/
> limits.h:11,
>                  from libstemmer_c/src_c/../runtime/header.h:2,
>                  from libstemmer_c/src_c/stem_ISO_8859_1_danish.c:4:
> /usr/lib/gcc/i486-linux-gnu/4.1.3/include/limits.h:122:61: error:
> limits.h: No such file or directory
> error: command 'gcc' failed with exit status 1
>
> Did anyone experience this before?
Nope, compiles out of the box for me on 7.1 (IIRC easy_install worked
for it as well).

> Any comment/suggestion is highly appreciated.
Do you have limits.h on your system?
Did you install the python2.5-dev package?

HTH,
--
Miki <miki.tebeka at gmail.com>
http://pythonwise.blogspot.com



More information about the Python-list mailing list