problem with Python 2.5.2 and gcc 4.3

David P. Riedel driedel at printingforsystems.com
Thu Mar 13 13:53:05 CET 2008


Andrew MacIntyre wrote:
> David P. Riedel wrote:
> 
>> I tried building Python 2.5.2 using gcc 4.3.0.  The build completes 
>> with no problems but when I run 'make test', I get a   segfault part 
>> way through the test run.
>>
>> here is the last part of the output from make test
>>
>> test_softspace
>> test_sort
>> test_sqlite
>> test_sqlite skipped -- no sqlite available
>> test_startfile
>> test_startfile skipped -- cannot import name startfile
>> test_str
>> make: *** [test] Segmentation fault
> 
> You don't identify the platform or O/S, though I'd guess some Linux
> distro on i386 or x86-64...
> 
> If you have gdb available, a backtrace might give a clue.
> 
> However, as this is a new major release of gcc I'm automatically going to
> assume an optimisation issue.  To test this I'd suggest doctoring the
> makefile generated by configure to reduce the optimisation level - I'd
> suggest trying -O instead of -O3.  If that works, try -O2 or -Os.
> 
> If -O2 or -Os works, I'd be taking the matter up with the gcc team.
> 
You are correct -- Mandriva Linux 2007.  I will try varying the optimization level and see what happens.

Thanks




More information about the Python-list mailing list