Will MySQLdb, the Python shim, be supported for Python 2.6 or 3.x?

Alia Khouri alia_khouri at yahoo.com
Wed Nov 19 05:54:19 CET 2008


> > John Nagle wrote:
>     Whoever did the port somehow created a dependency on the
> Intel math library, "libguide40.dll" and "libmmd.dll".  That shouldn't
> be needed in the MySQL Python shim.  It's not freely distributable,
> either; you have to buy the Intel C++ compiler to get it.  There are
> versions of those DLLs available on the web, but they may or may not
> be legitimate or current.

I'm aware of that, as I went through the same process, actually
discovered that dependency myself, and ended up having to use dlls off
the net. Eventhough I got this to work in the end, I ultimately found
that this isn't the only extension lib with 'issues', in 2.6 (numpy,
etc..) I finally ditched 2.6 for my app and reverted back to 2.5. My
recommendation is to do the same until things improve in extension
land.

AK



More information about the Python-list mailing list