More __init__ methods

Marc 'BlackJack' Rintsch bj_666 at gmx.net
Fri Nov 7 16:32:32 CET 2008


On Fri, 07 Nov 2008 15:16:29 +0000, Duncan Booth wrote:

> 'from_string' is a bad name here for your factory method: you should try
> to make it clear what sort of string is expected.

When I use a `from_string()` factory I usually make sure it can parse the 
`str()` form of that type or that there is a `to_string()` as reverse 
operation.

Ciao,
	Marc 'BlackJack' Rintsch



More information about the Python-list mailing list