Matplotlib on Leopard Mac OS

Massi massi_srb at msn.com
Thu Nov 27 00:12:57 CET 2008


Hi everyone, I've got some problems trying to install matplotlib on my
mac (Leopard OS). I'm following the instructions I found in the
official site to install it from the egg file (http://
matplotlib.sourceforge.net/users/installing.html), but when I run
easy_install ./matplotlib-0.98.3-py2.5-macosx-10.3.egg, I get this
error message:

BUILDING MATPLOTLIB
            matplotlib: 0.98.3
                python: 2.5.1 (r251:54863, Apr 15 2008, 22:57:26)
[GCC
                        4.0.1 (Apple Inc. build 5465)]
              platform: darwin

REQUIRED DEPENDENCIES
                        * numpy 1.1 or later is required; you have
1.0.1
error: Setup script exited with 1

In fact I did install numpy 1.2.1, so I can't understand why it
doesn't fin it! Any help? Thanks in advance.



More information about the Python-list mailing list