Python image library issue: domain users cannot save files?

Gabriel Genellina gagsl-py2 at yahoo.com.ar
Wed Nov 19 23:56:03 CET 2008


En Wed, 19 Nov 2008 13:43:07 -0200, vixvixreg at gmail.com  
<vixvixreg at gmail.com> escribió:

> Has anyone try to use PIL in a windows domain environment? I am having
> a permission issue. If I am a domain user, even I have the permission
> to write a folder, when I tried to do simple things like Image.open
> ("foo.tif").save("bar.tif"), i am getting exception IOError ("0",
> "Error"). I tried to set os.umask(0) before I saved the file but the
> same exception threw. But If I am the same domain user with local
> admin permission on a windows box, I have no problem with the same
> script. Does anyone ever have the same situation and know a work
> around for this? Thanks.

Try using the builtin open() function to create/read/write files. If you  
have the same issues then you can take away PIL from the question and  
concentrate on setting the proper permissions for the user running the  
script.

-- 
Gabriel Genellina




More information about the Python-list mailing list