strange permission issue with nosetests

Ben Finney bignose+hates-spam at benfinney.id.au
Thu Nov 20 13:34:08 CET 2008


Mr.SpOOn <mr.spoon21 at gmail.com> writes:

> Searching on google I found this: http://www.siafoo.net/article/61
> He had the same issue and said to change permission of the file to 664.
> 
> I tried and it worked.
> Is that normal? Why does it happen?

If a file is meant to be run as a command or program, make it
executable. (It would be good to *also* make the file behave well when
imported as a module instead.)

If it's meant to be imported as a module, do *not* make it executable.

Unit test modules, which are primarily meant to be imported and have
the tests collected and *then* run by the unit test framework, should
be non-executable modules. I'm very glad nose enforces this.

-- 
 \        “Humanity has advanced, when it has advanced, not because it |
  `\     has been sober, responsible, and cautious, but because it has |
_o__)            been playful, rebellious, and immature.” —Tom Robbins |
Ben Finney



More information about the Python-list mailing list