Installing packages

drobinow at gmail.com drobinow at gmail.com
Thu Nov 13 23:56:34 CET 2008


On Nov 13, 2:25 pm, Alan Baljeu <alanbal... at yahoo.com> wrote:
> I'm new to Python, and just downloaded Py2.6.  I also want to use Nose.  So I downloaded the latest sources, but it's not at all clear what's the best way to put this stuff into the Python package system.  Nose supports easy_install, easy_install doesn't have an installer for Windows and Py2.6, so I think I can't use that.  (It only does 2.5 and earlier.  (Should I go to Py2.5?  Is there more support out there for that?)).  
>
> Alan Baljeu
You are the second poster today concerned about the lack of setuptools
for Py2.6
All you have to do is download the setuptools source and run:
  C:\Python26\python setup.py install

You'll need a compatible compiler (Visual Studio Express 2008 works
fine) but if you're running Python on Windows you should have that
anyway or you'll forever be at the mercy of the packagers.





More information about the Python-list mailing list