Installing Python 2.4 over 2.4?

W. eWatson notvalid2 at sbcglobal.net
Tue Oct 14 23:00:09 CEST 2008


Terry Reedy wrote:
> Steve Holden wrote:
>> W. eWatson wrote:
>>> I suspect something has been corrupted in Python 2.4. Can I just
>>> re-install on top of it, and still expect to have scipy and other pkgs
>>> I've installed?
>>
>> On Windows, certainly - you can even uninstall and reinstall and retain
>> your installed libraries. On Linux I am pretty sure the same is true,
>> but caveat emptor.
> 
> In Windows, at least, micro version upgrades are handled exactly this 
> way.  When 2.5.3 comes out, for instance, the installer will replace 
> python files as needed in the current directories but leave 
> Python25/Lib/Site-Packages and any user-added directories alone.
> 
That's good news. I was worried about libraries I had set up.

-- 
                                W. eWatson

              (121.015 Deg. W, 39.262 Deg. N) GMT-8 hr std. time)
               Obz Site:  39° 15' 7" N, 121° 2' 32" W, 2700 feet

                     Web Page: <www.speckledwithstars.net/>




More information about the Python-list mailing list