installing python 3.0rc1 on Linux

tomohiro kusumi kusumi.tomohiro at
Wed Oct 15 20:38:31 CEST 2008

I installed python3.0 rc1 on Linux with --enable-shared option on configure
But the python3.0 says there is no although there is one
/usr/local/lib. The /etc/ script has that path in it too.

# python3.0
python3.0: error while loading shared libraries: cannot
open shared object file: No such file or directory

So I set the LD_LIBRARY_PATH, and now it works. I wonder why the python3.0
doesn't find the libpython under /usr/local/lib (which is the default
install path).

# export LD_LIBRARY_PATH=/usr/local/lib
# python3.0
Python 3.0rc1 (r30rc1:66499, Oct  8 2008, 23:23:02)
[GCC 4.1.2 20070626 (Red Hat 4.1.2-14)] on linux2
Type "help", "copyright", "credits" or "license" for more information.

Tomohiro Kusumi

2008/10/14 < at>

> I have a SUSE 10.3 OS
> I have the original python 2.5.1 loaded from the suse rpm.
> I have tried installing Python 3.0rc1 using the standard make
> technique with the "altinstall" variation. I don't want to replace my
> 2.5.1. I just want to try out the new Python 3.0.
> I have successfully installed the new version, but not the following
> modules.
> Failed to find the necessary bits to build these modules:
> _curses            _curses_panel      _dbm
> _gdbm              _hashlib           _sqlite3
> _ssl               _tkinter           bz2
> readline           zlib
> My original 2.5.1 version supports these modules, but the 3.0 does
> not.
> My older rpm version is installed in /usr/bin. I have installed the
> new Python 3.0 in /usr/local/bin.
> It seems that the make process cannot find some of the shared
> libraries. Is there some way to change the install process ( make,
> config files or whatever) to pick up support for these missing
> modules??
> Thanks,
> Brad Rogers
> --
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Python-list mailing list