[ANN] pysqlite 2.5.0 released

Gerhard Häring gh at ghaering.de
Mon Sep 8 13:56:43 CEST 2008


Matthias Huening wrote:
> Gerhard Häring (08.09.2008 10:12):
>>
>>> Error is:
>>>
>>> con.execute("select load_extension('./fts3.so')")
>>> pysqlite2._sqlite.OperationalError: Das angegebene Modul wurde nicht 
>>> gefunden.
>>>
>>> Where should I look for the module?
>>
>> The sources are in ext/fts3 in the SQLite source tree. I haven't found 
>> any Makefile, so I it myself using this gcc command:
>>
>> $ cd .../ext/fts3
>> $ gcc -shared -o ~/src/gh/pysqlite/build/lib.linux-i686-2.5/fts3.so 
>> *.c -lsqlite3
> 
> Thanks!
> Will fts3 be integrated in the Python 2.6 release?

No (only relevant on win32, where we also ship the SQLite DLL). Neither 
will be the ability to load extensions modules. It's just too late to 
add features now.

But AFAIK it's possible to compile a custom SQLite with appropriate 
flags to ./configure that will include the fulltext search extension.

-- Gerhard




More information about the Python-list mailing list