tkinter for my python program !!

karthikbalaguru karthikbalaguru79 at gmail.com
Sun Sep 14 16:21:01 CEST 2008


On Jul 22, 7:11 pm, "Diez B. Roggisch" <de... at nospam.web.de> wrote:
> karthikbalaguru wrote:
> > On Jul 22, 6:32 pm, "Diez B. Roggisch" <de... at nospam.web.de> wrote:
> >> karthikbalaguru wrote:
> >> > Hi,
>
> >> > One of my python program needs tkinter to be installed to run
> >> > successfully.
> >> > I am using Redhat 9.0 and hence tried installing by copying the
> >> > tkinter-2.2.2-36.i386.rpm
> >> > alone from the CD 3 to my pc. But, it is not getting installed and is
> >> > failing by throwing
> >> > the below errors. Should i need to configure / install any specific
> >> > files for resolving this issue ?
>
> >> > [root at localhost karthik]# rpm -ivh tkinter-2.2.2-26.i386.rpm
> >> > warning: tkinter-2.2.2-26.i386.rpm: Header V3 DSA signature: NOKEY,
> >> > key ID db42a
> >> > 60e
> >> > error: Failed dependencies:
> >> >         libtcl8.3.so is needed by tkinter-2.2.2-26.i386
> >> >         libtix8.1.8.3.so is needed by tkinter-2.2.2-26.i386
> >> >         libtk8.3.so is needed by tkinter-2.2.2-26.i386
>
> >> > Any ideas ?
>
> >> Yes: you should consider reading error-messages. What does
>
> >> error: Failed dependencies:
> >>          libtcl8.3.so is needed by tkinter-2.2.2-26.i386
> >>          libtix8.1.8.3.so is needed by tkinter-2.2.2-26.i386
> >>          libtk8.3.so is needed by tkinter-2.2.2-26.i386
>
> >> look like for you?
>
> >> Small hint: if you install something that depends on something else, you
> >> need to .... the missing dependency first. Fill in the dots...
>
> > I find that it needs python-2.2.2-26.i386 and hence i tried installing
> > python and i
> > land here :( :(
>
> > [root at localhost karthik]# rpm -ivh python-2.2.2-26.i386.rpm
> > warning: python-2.2.2-26.i386.rpm: Header V3 DSA signature: NOKEY, key
> > ID db42a60e
> > error: Failed dependencies:
> >         libdb-4.0.so is needed by python-2.2.2-26.i386
> >         python < 2.4.3-18.fc6 conflicts with python-
> > devel-2.4.3-18.fc6.i386
> > [root at localhost karthik]#
>
> > I find that python 2.4.3-18.fc6 is being used by many of applications.
> > But, the program i am trying to run needs python-2.2.2-26.
> > So, how to resolve this issue ?
>
> Are you *sure* it requires python2.2? If yes, why can't fedora install
> several python versions together? Ubuntu for sure can. But Python2.2 is
> *ancient* - you might need to compile it yourself.
>

Another method of resolving the whole problem
related to rpm dependencies was using
the 'yum' utility in Fedora Cores(I use FC2)
and 'up2date' utility in RedHat.

Karthik



More information about the Python-list mailing list