Cannot install pysqlite on Cygwin

Gerhard Häring gh at ghaering.de
Mon Sep 29 09:53:01 CEST 2008


Tilman Kispersky wrote:
> I am trying to install sqlite for use with python on cygwin. I have
> installed the sqlite packages from cygwin (that is libsqlite3-devel
> and libsqlite3_0).  When attempting to easy_install pysqlite I get:
> [...]
> build/temp.cygwin-1.5.25-i686-2.5/src/connection.o: In function
> `pysqlite_enable_load_extension':
> /cygdrive/c/Users/Tilman/AppData/Local/Temp/easy_install-876nHz/
> pysqlite-2.5.0/src/connection.c:922: undefined reference to
> `_sqlite3_enable_load_extension' [...]

It might be that Cygwin's SQLite doesn't support loading extensions.

Either:

Rebuild SQLite from source on Cygwin and be sure to include

--enable-load-extension when calling ./configure.

Or hack the pysqlite sources and remove these lines in src/connection.c:

#if SQLITE_VERSION_NUMBER >= 3003008
#define HAVE_LOAD_EXTENSION
#endif

I'm very interested how you can fix the problem.

-- Gerhar




More information about the Python-list mailing list