Checking the boolean value of a collection

Terry Reedy tjreedy at
Sat Sep 13 20:08:29 CEST 2008

Marco Bizzarri wrote:
> On Fri, Sep 12, 2008 at 4:09 PM, Diez B. Roggisch <deets at> wrote:
>> You should also consider using PEP8 style naming.
>> Diez
> class FolderInUse:
>     def __init__(self, core):
>         self.core = core
>     def true_for(self, archivefolder):
>         return any([instance.forbid_to_close(archivefolder) for instance in
>             self.core.active_outgoing_registration_instances()])
> Is this any better?

Yes.  Now I can read it to suggest shorter names (I agree with FL here).
I would consider 'outgoing' for 'a_o_r_i' and perhaps 'no_close' or 
'stay_open' or suggestions below for 'f_t_c'

> The true_for name does not satisfy me a lot...
> maybe because it is too similar to True.

Does one of 'locked', 'forbidden', 'untouchable' express the essence of 
the condition being tested?  I would consider using the same adjective 
to name the test on instances and the collection of instances, or maybe 
'x' and 'any_x'.

  Anyway, I'm trying a good
> naming so that code is readable, like:
> specification = FolderInUse(core)
> if specification.true_for(folder):
>    ...
> Any thought about this?


More information about the Python-list mailing list