Some test fail on my new Python 2.6

R. David Murray rdmurray at
Thu Apr 9 01:22:28 CEST 2009

Sorin Schwimmer <sxn02 at> wrote:
> /usr/local/lib is in /etc/ The files are real. However,
> creating symlinks in /usr/lib targeting the libraries in /usr/local/lib,
> then recompiling, solved the tkinter problem. So, the conclusion is that
> only /usr/lib is consulted for the tcl/tk libraries.

Hmm.  That's an issue with your linux setup, then, since python uses
system facilities to load the shared libraries.  I'm wondering
if you just needed to run might be that it hadn't
been run since you installed the libraries into /usr/local/lib...though
I would think the install process would have done that.

> multiprocessing - do I need it? Probably not. I can fork() a new process,
> so I can manage. I don't know what am I loosing without multiprocessing.

What you loose is the nice interprocesses communication facilities
provided by multiprocessing.  You might append your system details
(including the fact that you have /dev/shm) to that ticket, especially
if you think you are going to want to be running cooperating
processes that need to do more than just communicate via stdin/out.

> htttpservers is still failing the same.
> Everything is done as root.

I got failures (different failures) when I tried running that test as
root.  You might try running it as a regular user, both before
and after the install.

> I'll move on with make install.
> Thanks for your help; I'm progressing :-)

You are welcome.  Glad to be able to help out.

R. David Murray   

More information about the Python-list mailing list