Python Packages : A looming problem? packages might no longer work? (well not on your platform or python version anyway)

Daniel Fetchinson fetchinson at googlemail.com
Thu Apr 23 17:50:26 CEST 2009


>> The OP is just thinking out loud that it would be great if developers
>> could count on some help for testing various platforms and versions.
>> And I agree, it would indeed be great.
>>
>
> I think you interpreted the OP differently. As I said before the idea
> is not a bad one, but as a package developer I get to decide which
> platforms and versions my code supports.

Yes, I also think the original idea of the OP is a good one. And I
agree with you that the developers need to be in charge what
platform/version their code supports. Trouble is that currently if
they decide to support multiple versions and platform they don't have
any help from python.org or PyPI. It would be great if after a
developer decided to support some platforms and some versions there
was some infrastructural help in place.

Cheers,
Daniel


-- 
Psss, psss, put it down! - http://www.cafepress.com/putitdown



More information about the Python-list mailing list