pylucene installation problem on Ubuntu 9.04

KK dioxide.software at gmail.com
Thu Aug 6 20:49:26 CEST 2009


hi all,
I've trying to install pylucene on my linux box from last 2 days but
not able to do so. first i tried to install it using apt-get like
this,
kk-laptop$ sudo apt-get install pylucene
and it did install python2.5, python2.5-minimal and pylucene. I must
mention one thing that I already had python2.6 on my box as the
default python i.e /usr/bin/python is linked to python2.6. Anyway s,
now i started the python interpreter using "python" command from cli
and then to make sure pylucene has been installed i tried to import
the module and to my surprise it said "module pylucene not found".
I thought I should enter the python2.6 env and do the same , so i
tried starting the python2.6 interpreter using "python2.6" as the
command and tried importing the same module and again it failed giving
the same irritating message.
 As a final try i pulled the source code of pylucene and as per the
comments given there in the README file, copied the mentioned files to
site-packages directory of python2.6 and then tried importing the
module and then got the same error message saying no module name
pylucene is present. I'm sick of this error !
Can someone point me what is the issue? If it is due to multiple
version of python running on box, can someone tell me which one to
remove or someone tell me how to get the whole thing running? I'll
very much thankful to you guys.

Thanks,
KK.



More information about the Python-list mailing list