install package in a particular python version

Steve1234 sflennik at comcast.net
Fri Aug 21 02:57:53 CEST 2009


I installed the boto module in my Ubuntu system using "python setup.py
install" and it installs in my python2.6 version and works great.  Now
I want to install boto into my python2.5 version because my hosting
services supports 2.5 but not 2.6. and I want to test my code locally,
"sting".format() is not in 2.5.

How do I install a package in a particular version of python?

I tried several different install switches without any luck.



More information about the Python-list mailing list