PyGTK problems after Linux update...

barcaroller barcaroller at
Fri Aug 28 01:20:00 CEST 2009

I use a python-based program called 'meld' which worked fine until my latest 
Fedora11/KDE4.3 update; it now gives me the following error:

    prompt> meld

    /usr/lib/python2.6/site-packages/gtk-2.0/glib/ undefined 
symbol: PyUnicodeUCS4_DecodeUTF8
    Meld requires pygtk 2.8.0 or higher.

If I run another GTK-based utility, I also get errors:

    prompt> gedit

    ** (gedit:28289): WARNING **: Error initializing Python interpreter: 
could not import pygtk.

I have installed the latest PyGTK (pygtk-2.14.1), to no avail.  Googling 
these messages have also produced no major results.  When I run 
'pygtk-demo', I get the following errors:

    prompt> python /usr/lib/pygtk/2.0/

    Traceback (most recent call last):
    File "/usr/lib/pygtk/2.0/", line 18, in <module>
        import gobject
    File "/usr/lib/python2.6/site-packages/gtk-2.0/gobject/", 
line 33, in <module>
        from glib import spawn_async, idle_add, timeout_add, 
timeout_add_seconds, \
    File "/usr/lib/python2.6/site-packages/gtk-2.0/glib/", line 
30, in <module>
        from glib._glib import *
    ImportError: /usr/lib/python2.6/site-packages/gtk-2.0/glib/ 
undefined symbol: PyUnicodeUCS4_DecodeUTF8

Does anyone know what needs to be done to resolve this?  Using Python 2.6.2 
on Fedora11/KDE4.3 32-bit i386/i586/i686.

More information about the Python-list mailing list