pyZui - anyone know about this?

David Roberts d at vidr.cc
Thu Dec 17 09:51:03 CET 2009


> /home/fetchinson/pyzui/pyzui/tilestore.py:22: DeprecationWarning: the
> sha module is deprecated; use the hashlib module instead
>   import sha
Yeah, I'd noticed that. It's fixed in the repository now.

On Dec 16, 10:55 pm, Daniel Fetchinson <fetchin... at googlemail.com>
wrote:
> > PyZUI 0.1 has been released:
>
> >http://da.vidr.cc/projects/pyzui/
>
> Cool, thanks very much!
>
> I'm using python 2.6 these days and noticed that you use the sha
> module which makes py2.6 spit out a deprecation warning:
>
> /home/fetchinson/pyzui/pyzui/tilestore.py:22: DeprecationWarning: the
> sha module is deprecated; use the hashlib module instead
>   import sha
>
> It's no big deal but if you want to be future proof maybe you can
> switch to hashlib for py2.6 and stay with sha for py2.5 and before (a
> try/except block would suffice).
>
> Cheers,
> Daniel
>
> --
> Psss, psss, put it down! -http://www.cafepress.com/putitdown




More information about the Python-list mailing list