Which is more pythonic?
Edward A. Falk
falk at mauve.rahul.net
Thu Dec 3 22:07:42 EST 2009
In article <mailman.1375.1259885328.2873.python-list at python.org>,
Filip GruszczyĆ
ski <gruszczy at gmail.com> wrote:
>
>for choice in self.__choices:
> choicesBox.addItem(choice)
This is the easiest to read. I'm guessing that this is not inner-loop
stuff that needs to be optimized, so you should favor readability over
performance.
--
-Ed Falk, falk at despams.r.us.com
http://thespamdiaries.blogspot.com/
More information about the Python-list
mailing list