code review
Lie Ryan
lie.1296 at gmail.com
Wed Dec 23 09:20:34 EST 2009
On 12/23/2009 11:02 PM, Zubin Mithra wrote:
> Hello,
>
> I`m pretty new to developing applications using python and i would
> like advance on this script i recently created which helps linux
> programmers on the linux terminal. The code is very simple to
> understand(i hope) and serves a simple purpose; however i am not sure
> if my way of scripting is the right "pythonic" way of doing it.
>
> The package can be found at www.code.google.com/p/pyautorun
>
> I`d love any feedback, ideas and criticism after a code review. Thank
> you in advance.
>
> cheers!!!
> Zubin Mithra
- you should look at os.path.exists(), os.path.splitext()
- try to use %-interpolation or .format(); the code would look much
nicer and much more readable. Tips: store the format string in the dict;
then you can just do something like fmt % {'infile': infile, 'outfile':
outfile}
- don't put comments on the right of the code; its ugly. Move it above
the code being described.
PS: it's extension not extention
More information about the Python-list
mailing list