"metaclass conflict" error: where is noconflict ?

Barak, Ron Ron.Barak at lsi.com
Thu Feb 19 14:01:07 CET 2009


Hi,

I have a class derived from two parents (in blue below), which gives me the following error:

$ python -u ./failover_pickle_demo09.py
Traceback (most recent call last):
  File "./failover_pickle_demo09.py", line 291, in <module>
    class ListControl(wx.Frame, CopyAndPaste):
TypeError: Error when calling the metaclass bases
    metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases
Googling suggested I should add

from noconflict import classmaker
and

__metaclass__=classmaker()
to this class.

However, I don't seem able to find where to get the noconflict module from.

Do any of you where noconflict  could be downloaded/installed from ?

Thanks,
Ron.

P.S.: I use Windows XP/cygwin, Python 2.5.2, wx-2.8-msw-unicode
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-list/attachments/20090219/075f5062/attachment.html>


More information about the Python-list mailing list