why cannot assign to function call

rurpy at yahoo.com rurpy at yahoo.com
Thu Jan 8 00:06:47 CET 2009

On Jan 6, 9:20 pm, Mark Wooding <m... at distorted.org.uk> wrote:
> ru... at yahoo.com <ru... at yahoo.com> wrote:
> > Is not the proper term "aliasing"?  Perhaps Python "variables" should
> > be called "alises".
> No.  The proper term is most definitely `binding': see SICP, for
> example.  (Wikipedia has a link to the full text.)

I thought you were objecting to Python's use of the term "binding"
when you wrote:

> Unfortunately, this practice causes other confusion, since `binding' is
> often used (in other language communities, notably Lisp and the
> functional languages) to describe the association between names and
> slots that hold references.

in response to someone talking about "...all those who use the term
\"name binding\" instead of variable assignment...".

More information about the Python-list mailing list