DrPython and py2exe

mk mrkafk at gmail.com
Fri Jan 23 16:52:42 CET 2009


imageguy wrote:

> drPython is probably selecting a specific version of wxpython and
> py2exe doesn't like it or
> can't find it. Once you solve that, py2exe will work fine with
> wxpython.

Thanks, drPython was indeed making use of wxversion.select. What's 
strange is that it was selecting apparently correct version:

import wxversion
wxversion.select('2.8')

I put this in setup.py:

import wxversion
wxversion.select("2.8.9.1")
import wx

..and it worked.

Regards,
mk





More information about the Python-list mailing list