"The application has failed to start because the application configuration is incorrect"

Carl Banks pavlovevidence at gmail.com
Wed Jan 28 05:59:29 CET 2009


Perhaps someone who's familiar with Windows XP and Python can figure
this one out, because it's baffling me.  I installed the following
packages on a more or less clean XP system:

Python 2.6.1, straight from the MSI.
WxPython 2.8.9.1, straight from the windows installer.

Both installed with no errors.  However, all attempts to run any wx
code resulted in the following exception:

"Import Error: DLL load failed: The application has failed to start
because the application configuration is incorrect.  Reinstalling the
application may fix the problem."

In fact, this seemed to be the case for any third-party extension
module.  I tried several other libraries for comparison (gtk, qt);
they all had the same problem, and right out of the box.  After a lot
of reading I figured that I didn't have the right MSVSRT DLLs on my
system, and that I should install the runtime redistributable packages
from Microsoft.  But I find it hard to believe the state of things in
Windows is that you have to ask the user to install a package from
Microsoft just to run an extension library.  A package, I might add,
that requires Adminstrative privileges.  Which I don't have.

Tkinter worked fine, BTW.

My questions are 1. is that really what Windows extension users are
expected to do, 2. if not, what else might be wrong, and 3. are there
any workarounds?


Carl Banks



More information about the Python-list mailing list