Weird invisible arguments issues with Windows

MRAB google at
Thu Jan 29 18:12:41 CET 2009

Uberman wrote:
> I've installed Python 2.6.1 (AMD64) under Windows Vista Ultimate 64-bit.
> First off, it didn't register the extension for .PY (although it did register
> .PYC).
> After manually associating the .PY extension with the python.exe executable, I
> am now getting some weirdness on the command line.  When I run the following
> script, saved as "", by simply entering " -r -d" on the
> command line, it produces the output "1":
>     import sys
>     if __name__ == "__main__":
>         print len(sys.argv)
> It doesn't see the additional arguments for some reason.  However, if I
> execute the script by prefixing it (i.e., "python -r -d"), I get an
> output of "3", meaning it sees the additional arguments.
> Has anybody else run into this issue?  And perhaps (hopefully) solved it?
You might want to check that:

     assoc .py




     ftype Python.File


     Python.File="C:\Python26\python.exe" "%1" %*

(or something similar).

More information about the Python-list mailing list