Is Psyco good for Python 2.6.1?

Mensanator mensanator at aol.com
Fri Jul 3 02:34:31 CEST 2009


On Jul 2, 5:41 pm, "Russ P." <Russ.Paie... at gmail.com> wrote:
> I need to speed up some Python code, and I discovered Psyco. However,
> the Psyco web page has not been updated since December 2007. Before I
> go to the trouble of installing it, does anyone know if it is still
> good for Python 2.6.1? Thanks.

Go back to the web site and look at the download page.

Usually, the download page will list various versions
to use with various Python versions. If it lists a
2.4 version, a 2.5 version, but no 2.6 version, most likely
the authors haven't yet made a 2.6 version so you're SOL.

Even that isn't guaranteed to always work. For instance,
the authors of the smpy module didn't think they needed
a seperate 2.6 version (and didn't make any effort to
actually try it 2.6). Turned out to be dead wrong on that
and had to scramble to release a fix.



More information about the Python-list mailing list